Scenario-2.2 Branch Office Network Setup – Configure and Verify Inter-Switch Link Settings

The Scene

Following on from the previous Lab Scenario-2.1 where we applied basic Universal Switch configuration, we will now configure the inter-switch connections.

The Goal

A Static Layer 2 Etherchannel Trunk to be configured between Core-1A and Core-1B.

A Dynamic Layer 2 Etherchannel Trunk using LACP to be configured between UserAcc-1A and UserAcc-1B.

A Dynamic Layer 2 Etherchannel Trunk using PAGP to be configured between UserAcc-1A and UserAcc-1B.

The trunks between the Core Switches and UserAcc Switches should be dynamically negotiated with the Core Switches actively negotiating the trunks.

Scenario-2.2

Resources

Enable Secret on all switches is levelup.

Download, import and run in Cisco VIRL the Scenario-2.2 Topology File.

Cisco’s Campus LAN Layer 2 Access with Simplified Distribution Deployment Guide.

The High Level Steps

Before making any port configuration changes we will enable synchronous logging on the switches Console port.

First we will start by configuring the Static 802.1Q Etherchannel Trunk required between Core-1A and Core-1B.

Once the Etherchannel connection is configured, verify it is up and is functioning as expected.

Next we will configure the four ports on the two Core Switches that are connected to the UserAcc switches. As we will want these trunk links to be negotiated dynamically by the Core Switches we will configure these ports with the dynamic desirable command.

Moving on to the UserAcc-1 switches located in Wire Closet 1:

  • Configure the ports on UserAcc-1A facing Core-1A and UserAcc-1B facing Core-1B with dynamic auto trunk negotiation settings and verify they are functioning as expected.
  • Configure a dynamically negotiated LACP Etherchannel trunk on the two ports connecting UserAcc-1A and UserAcc-1B, with switch UserAcc-1A actively negotiating the connection and verify it is functioning as expected.

Moving on to the UserAcc-2 switches located in Wire Closet 2:

  • Configure the ports on UserAcc-2A facing Core-1B and UserAcc-2B facing Core-1A with dynamic auto trunk negotiation settings and verify they are functioning as expected.
  • Configure a dynamically negotiated PAgP Etherchannel trunk on the two ports connecting UserAcc-2A and UserAcc-2B, with switch UserAcc-2A actively negotiating the connection and verify it is functioning as expected.

All ports should be given a meaningful description that documents the device that it is connected to.

All switches should have their configured Etherchannels to use source and destination IP address information when calculating which links in the bundle to send traffic across.

All trunks should use 802.1Q encapsulation.

All Trunks should be configured to allow all VLANs over them.

The Solution

Configure Console Port Synchronous Logging, EtherChannel Load Balancing and a Static Etherchannel Trunk between the two Core Switches :

line console 0
logging synchronous
!
port-channel load-balance src-dst-ip
!
interface range gi0/1 – 2
 description to {opposite switch hostname}
 channel-group 1 mode on
!
interface port-channel 1
 description Etherchannel to {opposite switch hostname}
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan all 
 no shutdown
!

Verify Inter-Core Switch Etherchannel status (see text highlighted in bold below):

show etherchannel summary
!
Number of channel-groups in use: 1
Number of aggregators:           1
Group  Port-channel  Protocol    Ports
——+————-+———–+———————————————–
1      Po1(SU)          –        Gi0/1(P)    Gi0/2(P)    
!

Configure Core Switch Ports facing UserAcc Switches:

interface gi0/3
description to {opposite switch hostname}
!
interface gi1/0
description to {opposite switch hostname}
!
interface range gi0/3 , gi1/0
switchport trunk encapsulation dot1q
switchport mode dynamic desirable
switchport trunk allowed vlan all 

!

For the UserAcc Switches hosted in Wire Closet 1, configure Console Port synchronous logging and configure and verify UserAcc switches trunk port connections up to the Core Switches:

line console 0
logging synchronous
!
interface gi0/3
 description to {opposite switch hostname}
 switchport trunk encapsulation dot1q
 switchport mode dynamic auto
 switchport trunk allowed vlan all
!
end
!

Verify Trunk Status (see text highlighted in bold below):

show interfaces gi0/3 switchport
Name: Gi0/3
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On

Configure and verify a LACP Etherchannel Trunk between UserAcc-1A and UserAcc-1B with Port Channel Load Balancing:

port-channel load-balance src-dst-ip
!
interface range gi0/1 – 2
description to {opposite switch hostname}
channel-protocol lacp
channel-group 1 mode {UserAcc-1A = active / UserAcc-1B= passive}
!
interface port-channel 1
description {opposite switch hostname}
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan all
no shutdown
!
show etherchannel summary
Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
——+————-+———–+———————————————–
1 Po1(SU) LACP Gi0/1(P) Gi0/2(P)

For the UserAcc Switches hosted in Wire Closet 2, configure Console Port synchronous logging and configure and verify UserAcc switches trunk port connections up to the Core Switches:

line console 0
logging synchronous
!
interface gi0/3
 description to {opposite switch hostname}
 switchport trunk encapsulation dot1q
 switchport mode dynamic auto
 switchport trunk allowed vlan all
!
end
!

Verify Trunk Status (see text highlighted in bold below):

show interfaces gi0/3 switchport
Name: Gi0/3
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On

Configure and verify a PAgP Etherchannel Trunk between UserAcc-2A and UserAcc-2B with Port Channel Load Balancing:

port-channel load-balance src-dst-ip
!
interface range gi0/1 – 2
description to {opposite switch hostname}
channel-protocol pagp
channel-group 1 mode {UserAcc-2A = desirable  / UserAcc-1B= auto}
!
interface port-channel 1
description {opposite switch hostname}
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan all
no shutdown
!
show etherchannel summary
Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
——+————-+———–+———————————————–
1 Po1(SU) LACP Gi0/1(P) Gi0/2(P)

 

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.